Connectivity Issues
Incident Report for SalesScreen
Resolved
The incident appears to be resolved, and all our services have returned to normal service.
Posted May 03, 2019 - 00:04 CEST
Monitoring
Our services appears to be returning to normal operation again. We are carefully monitoring the situation.
Posted May 02, 2019 - 23:09 CEST
Identified
Our service provider Microsoft Azure is having global outage that affects all our services. We are monitoring the situation and doing everything in our power to restore connectivity to SalesScreen.

We will keep this page updated as we learn more about the situation.
Posted May 02, 2019 - 22:50 CEST
Investigating
We are currently investigating increased error rates and connectivity issues to the application. All parts of the system appears to be affected.
Posted May 02, 2019 - 22:26 CEST
This incident affected: Web, Mobile, Screens, and API.