Login issues in Internet Explorer and Screen issues on Dogu Connect
Incident Report for SalesScreen
Resolved
This incident has been resolved.
Posted about 2 years ago. May 24, 2017 - 11:43 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 years ago. May 24, 2017 - 09:38 CEST
Investigating
We are investigating that matter and we'll update this page as soon as we have more information.
Posted about 2 years ago. May 24, 2017 - 08:35 CEST