Issues with 2-Factor Authentication via SMS
Incident Report for SalesScreen
Resolved
Our SMS delivery provider has solved their problem, and the 2FA functionality should now work as normal.
Posted almost 2 years ago. Sep 11, 2017 - 22:57 CEST
Monitoring
The issue appears to be resolved but we are following closely.
Posted almost 2 years ago. Sep 11, 2017 - 16:56 CEST
Investigating
We are currently facing issues with our SMS delivery provider.
This impacts our users using 2-Factor Authentication via SMS.
We are actively investigating this issue and will update that incident as soon as we have more information available.

If you are impacted by this, we recommend that you use Email instead of SMS as the 2FA Method.
If you are still not able to login, reach out to us on the chat and we will assist you.
Thanks a lot for your patience.
Posted almost 2 years ago. Sep 11, 2017 - 10:45 CEST