DNS issues in the UK
Incident Report for SalesScreen
Resolved
The issue has been resolved by our DNS provider
Posted over 2 years ago. Mar 02, 2017 - 20:58 CET
Identified
We have identified a problem with our DNS provider in the UK. As a result customers based in this region might have difficulties accessing our website.
Posted over 2 years ago. Mar 02, 2017 - 16:45 CET