Connectivity Issues

Incident Report for SalesScreen

Resolved

This incident has been resolved, all services are back to normal.
Posted Oct 30, 2025 - 09:00 CET

Monitoring

We are now seeing clear signs of recovery across all our services. We will continue to monitor the situation to ensure full stability.
Posted Oct 29, 2025 - 21:32 CET

Update

We have failed over some of our services, which means the Mobile app and API should start recovering shortly. Microsoft, our cloud provider, has identified the source of the issue and expects recovery within the next 30 minutes. We will continue to monitor the situation and provide updates as needed. Thank you for your patience.
Posted Oct 29, 2025 - 19:16 CET

Identified

We have identified an issue with our provider and are actively working on a fix.
Posted Oct 29, 2025 - 17:03 CET

Investigating

We are investigating an issue affecting connectivity to our services.
Posted Oct 29, 2025 - 16:56 CET
This incident affected: Web, Mobile, and API.