Outreach Integration Issue

Incident Report for SalesScreen

Resolved

This incident has been resolved. Affected customers can now re-authenticate the integration to resume operation.
Posted Mar 31, 2025 - 13:03 CEST

Update

A temporary solution is now available. To restore functionality, customers need to re-authenticate the Outreach integration from the SalesScreen web dashboard. This solution uses a development version of the Outreach integration.

We are actively working with Outreach to get a production version approved.
Posted Mar 28, 2025 - 11:22 CET

Identified

The issue has been identified and we are working with Outreach to resolve it.
Posted Mar 27, 2025 - 21:10 CET

Investigating

We are currently investigating an issue with our integration towards Outreach. No activities are currently being synced to SalesScreen, all customers using this integration appears to be affected.
Posted Mar 27, 2025 - 13:35 CET
This incident affected: API.