Support system is undergoing downtime
Incident Report for SalesScreen
Resolved
This incident has been resolved.
Posted about 3 years ago. Sep 21, 2016 - 18:07 CEST
Update
Our Support system is currently totally unavailable either on email or chat. We keep on monitoring closely the progress made by Intercom.
Posted about 3 years ago. Sep 21, 2016 - 17:11 CEST
Investigating
We are following up closely with Intercom, our support system provider.
Posted about 3 years ago. Sep 21, 2016 - 16:29 CEST