Support System is undergoing an outage
Incident Report for SalesScreen
Resolved
The issue has now been resolved.
Posted almost 3 years ago. Oct 21, 2016 - 14:51 CEST
Investigating
Our Support System Intercom is currently undergoing an outage.
As a result, we currently cannot answer incoming support requests.
We are following closely the progress that the Intercom team is making on resolving this issue.
Posted almost 3 years ago. Oct 21, 2016 - 13:40 CEST