SalesScreen Documentation unavailable
Incident Report for SalesScreen
Resolved
Our Documentation page is accessible again. Thanks for your patience
Posted almost 2 years ago. Sep 25, 2017 - 11:20 CEST
Investigating
Our documentation page (help.salesscreen.com) is currently unavailable due to an outage on the third party application we are relying on. We are monitoring closely this and will update this issue as soon as we have more information available.
Thanks for your patience and we are deeply sorry about the inconvenience.
Posted almost 2 years ago. Sep 25, 2017 - 10:44 CEST