Issues with integrations

Incident Report for SalesScreen

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 13:48 CEST

Identified

We have identified the issue, and are working on remediating the issue
Posted Apr 02, 2026 - 12:00 CEST

Investigating

We are currently investigating an issue with some of our integrations, including Salesforce and Hubspot
Posted Apr 02, 2026 - 11:50 CEST